summaryrefslogtreecommitdiff
path: root/customized/prosody.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2017-02-12 23:12:35 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2017-02-12 23:12:35 +0100
commitcf92c8d096fac5cbe786bf1cbe69a7806e2f0d7e (patch)
treef082f48e2a44a5a547c790cc4cba193434f2ad68 /customized/prosody.nix
parent7382aad9c3ed764bd56700ca2e9879a6fc6692d7 (diff)
downloadnixos-cf92c8d096fac5cbe786bf1cbe69a7806e2f0d7e.tar
nixos-cf92c8d096fac5cbe786bf1cbe69a7806e2f0d7e.tar.gz
nixos-cf92c8d096fac5cbe786bf1cbe69a7806e2f0d7e.tar.bz2
nixos-cf92c8d096fac5cbe786bf1cbe69a7806e2f0d7e.tar.xz
nixos-cf92c8d096fac5cbe786bf1cbe69a7806e2f0d7e.zip
Link prosody against lua5_sec
Diffstat (limited to 'customized/prosody.nix')
-rw-r--r--customized/prosody.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/customized/prosody.nix b/customized/prosody.nix
index a3445517..c7ca03c5 100644
--- a/customized/prosody.nix
+++ b/customized/prosody.nix
@@ -1,5 +1,5 @@
1{ stdenv, fetchurl, libidn, openssl, makeWrapper, fetchhg 1{ stdenv, fetchurl, libidn, openssl, makeWrapper, fetchhg
2, lua5, luasocket, luasec, luaexpat, luafilesystem, luabitop, luaevent ? null, luazlib ? null 2, lua5, luasocket, lua5_sec, luaexpat, luafilesystem, luabitop, luaevent ? null, luazlib ? null
3, withLibevent ? true, withZlib ? true 3, withLibevent ? true, withZlib ? true
4, communityModules ? [], extraLibs ? [], extraModules ? [] 4, communityModules ? [], extraLibs ? [], extraModules ? []
5}: 5}:
@@ -10,7 +10,7 @@ assert withZlib -> luazlib != null;
10with stdenv.lib; 10with stdenv.lib;
11 11
12let 12let
13 libs = [ luasocket luasec luaexpat luafilesystem luabitop ] 13 libs = [ luasocket lua5_sec luaexpat luafilesystem luabitop ]
14 ++ optional withLibevent luaevent 14 ++ optional withLibevent luaevent
15 ++ optional withZlib luazlib 15 ++ optional withZlib luazlib
16 ++ extraLibs; 16 ++ extraLibs;
@@ -40,7 +40,7 @@ stdenv.mkDerivation rec {
40 sha256 = "0010x2rl9f9ihy2nwqan2jdlz25433srj2zna1xh10490mc28hij"; 40 sha256 = "0010x2rl9f9ihy2nwqan2jdlz25433srj2zna1xh10490mc28hij";
41 }; 41 };
42 42
43 buildInputs = [ lua5 luasocket luasec luaexpat luabitop libidn openssl makeWrapper ] 43 buildInputs = [ lua5 luasocket lua5_sec luaexpat luabitop libidn openssl makeWrapper ]
44 ++ optional withLibevent luaevent 44 ++ optional withLibevent luaevent
45 ++ optional withZlib luazlib; 45 ++ optional withZlib luazlib;
46 46