summaryrefslogtreecommitdiff
path: root/custom/wombat.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2015-06-12 19:43:47 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2015-06-12 19:43:47 +0200
commit8fb479ae5ac335e67413189984adaaaed0fbf4db (patch)
tree77359d1cc7b18123ee5d6d0b405fe435865d2620 /custom/wombat.nix
parenteb5a39aee4c9f4767f23911495d7a72e5bf27471 (diff)
downloadnixos-8fb479ae5ac335e67413189984adaaaed0fbf4db.tar
nixos-8fb479ae5ac335e67413189984adaaaed0fbf4db.tar.gz
nixos-8fb479ae5ac335e67413189984adaaaed0fbf4db.tar.bz2
nixos-8fb479ae5ac335e67413189984adaaaed0fbf4db.tar.xz
nixos-8fb479ae5ac335e67413189984adaaaed0fbf4db.zip
beuteltiere
Diffstat (limited to 'custom/wombat.nix')
-rw-r--r--custom/wombat.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/custom/wombat.nix b/custom/wombat.nix
new file mode 100644
index 00000000..baeac700
--- /dev/null
+++ b/custom/wombat.nix
@@ -0,0 +1,29 @@
1# This file was auto-generated by cabal2nix. Please do NOT edit manually!
2
3{ cabal, aeson, beuteltier, filepath, lenses, mtl
4, optparseApplicative, text, time, transformers
5, unorderedContainers, vector
6, fetchgit
7}:
8
9cabal.mkDerivation (self: {
10 pname = "wombat";
11 version = "0.4.0";
12 src = fetchgit {
13 url = git://git.yggdrasil.li/wombat;
14 # nix-shell -p nix-prefetch-scripts --command 'nix-prefetch-git git://git.yggdrasil.li/wombat' 2>&1 | grep -E '(git revision|hash) is ' | sed -r 's/git revision is /rev = "/' | sed -r 's/hash is /sha256 = "/' | sed -r 's/$/";/'
15 rev = "8f1b1ed05d12a0f5f47a7834d4878d2a3e8014d3";
16 sha256 = "f441971623f3f2a35df9feae0ac927b5447d62fede33fd67bb54baeb08468a51";
17 };
18 isLibrary = false;
19 isExecutable = true;
20 buildDepends = [
21 aeson beuteltier filepath lenses mtl optparseApplicative text time
22 transformers unorderedContainers vector
23 ];
24 meta = {
25 description = "A Beuteltier";
26 license = self.stdenv.lib.licenses.publicDomain;
27 platforms = self.ghc.meta.platforms;
28 };
29})