summaryrefslogtreecommitdiff
path: root/custom/uucp-notifyclient.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2018-06-02 18:44:59 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2018-06-02 18:44:59 +0200
commit9e8b1443806cf8e9eb004853b1547a5cc0c0d316 (patch)
tree3f9aa1d314d1e0f5bf245bb31707de5505d1001c /custom/uucp-notifyclient.nix
parent6a01f3e5e6c7c9d97f8fdc9a091d3d0810030cdc (diff)
downloadnixos-9e8b1443806cf8e9eb004853b1547a5cc0c0d316.tar
nixos-9e8b1443806cf8e9eb004853b1547a5cc0c0d316.tar.gz
nixos-9e8b1443806cf8e9eb004853b1547a5cc0c0d316.tar.bz2
nixos-9e8b1443806cf8e9eb004853b1547a5cc0c0d316.tar.xz
nixos-9e8b1443806cf8e9eb004853b1547a5cc0c0d316.zip
...
Diffstat (limited to 'custom/uucp-notifyclient.nix')
-rw-r--r--custom/uucp-notifyclient.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/custom/uucp-notifyclient.nix b/custom/uucp-notifyclient.nix
index be6284b1..4cc51b9c 100644
--- a/custom/uucp-notifyclient.nix
+++ b/custom/uucp-notifyclient.nix
@@ -18,7 +18,7 @@ in {
18 services.uucp.notify-client = { 18 services.uucp.notify-client = {
19 remoteNodes = mkOption { 19 remoteNodes = mkOption {
20 type = with types; attrsOf (submodule nodeConfig); 20 type = with types; attrsOf (submodule nodeConfig);
21 default = []; 21 default = {};
22 description = '' 22 description = ''
23 Servers to receive notifications from 23 Servers to receive notifications from
24 ''; 24 '';
@@ -29,7 +29,7 @@ in {
29 imports = [ ./notify-users.nix ]; 29 imports = [ ./notify-users.nix ];
30 30
31 config = mkIf (cfg.remoteNodes != {}) { 31 config = mkIf (cfg.remoteNodes != {}) {
32 services.notify-users = concatMap ({ allowedUsers }: allowedUsers) cfg.remoteNodes; 32 services.notify-users = concat (mapAttrsToList ({ allowedUsers, ... }: allowedUsers) cfg.remoteNodes);
33 33
34 services.uucp.remoteNodes = mapAttrs (name: { allowedUsers, ... }: { commands = map (user: "notify-${user}") allowedUsers; }) cfg.remoteNodes; 34 services.uucp.remoteNodes = mapAttrs (name: { allowedUsers, ... }: { commands = map (user: "notify-${user}") allowedUsers; }) cfg.remoteNodes;
35 services.uucp.commandPath = [ config.security.wrapperDir ]; 35 services.uucp.commandPath = [ config.security.wrapperDir ];