summaryrefslogtreecommitdiff
path: root/custom/trivmix-service.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2017-03-09 16:46:33 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2017-03-09 16:46:33 +0100
commitfd5865d6f7fcd39ab1a1a2c0cb57c98c16e1ae9e (patch)
tree669a3dd489a025e48f2423c69598311b2b03b3bb /custom/trivmix-service.nix
parent7ef554f858013163087a05ee3811ddadbc2a0109 (diff)
downloadnixos-fd5865d6f7fcd39ab1a1a2c0cb57c98c16e1ae9e.tar
nixos-fd5865d6f7fcd39ab1a1a2c0cb57c98c16e1ae9e.tar.gz
nixos-fd5865d6f7fcd39ab1a1a2c0cb57c98c16e1ae9e.tar.bz2
nixos-fd5865d6f7fcd39ab1a1a2c0cb57c98c16e1ae9e.tar.xz
nixos-fd5865d6f7fcd39ab1a1a2c0cb57c98c16e1ae9e.zip
revert to having .out
Diffstat (limited to 'custom/trivmix-service.nix')
-rw-r--r--custom/trivmix-service.nix36
1 files changed, 19 insertions, 17 deletions
diff --git a/custom/trivmix-service.nix b/custom/trivmix-service.nix
index 04f1634b..e9120f88 100644
--- a/custom/trivmix-service.nix
+++ b/custom/trivmix-service.nix
@@ -24,22 +24,24 @@ let
24 ''; 24 '';
25 inherit (stdenv.lib) optionalString; 25 inherit (stdenv.lib) optionalString;
26in { 26in {
27 wantedBy = [ "sound.target" ]; 27 out = {
28 requires = [ "jack.service" ]; 28 wantedBy = [ "sound.target" ];
29 before = [ "mpd.service" ]; 29 requires = [ "jack.service" ];
30 serviceConfig = { 30 before = [ "mpd.service" ];
31 Type = "simple"; 31 serviceConfig = {
32 ExecStart = ''${trivmix}/bin/trivmix --client ${name} \ 32 Type = "simple";
33 ${optionalString connect "--run ${connectScript}"} \ 33 ExecStart = ''${trivmix}/bin/trivmix --client ${name} \
34 ${optionalString (! isNull run) "--run ${run}"} \ 34 ${optionalString connect "--run ${connectScript}"} \
35 ${optionalString (! isNull initial) "--level ${initial}"} \ 35 ${optionalString (! isNull run) "--run ${run}"} \
36 /dev/shm/mix/${name}/level \ 36 ${optionalString (! isNull initial) "--level ${initial}"} \
37 ${optionalString (! isNull group) "/dev/shm/mix/${group}/level"} 37 /dev/shm/mix/${name}/level \
38 ''; 38 ${optionalString (! isNull group) "/dev/shm/mix/${group}/level"}
39 User = "jack"; 39 '';
40 Group = "audio"; 40 User = "jack";
41 Nice = "-10"; 41 Group = "audio";
42 LimitRTPRIO = "95:95"; 42 Nice = "-10";
43 LimitMEMLOCK = "infinity"; 43 LimitRTPRIO = "95:95";
44 LimitMEMLOCK = "infinity";
45 };
44 }; 46 };
45} 47}