summaryrefslogtreecommitdiff
path: root/custom/opossum.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2015-06-13 15:42:24 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2015-06-13 15:42:24 +0200
commit76a0579933da3ed3ea6a39731a8c50e592c3d7e4 (patch)
tree84ed7eff9019b55ad86f1b733383f96a6e3d5ebd /custom/opossum.nix
parent7fdb3c3a45a3b71ea8ccb35e2801eaee9e4044ef (diff)
downloadnixos-76a0579933da3ed3ea6a39731a8c50e592c3d7e4.tar
nixos-76a0579933da3ed3ea6a39731a8c50e592c3d7e4.tar.gz
nixos-76a0579933da3ed3ea6a39731a8c50e592c3d7e4.tar.bz2
nixos-76a0579933da3ed3ea6a39731a8c50e592c3d7e4.tar.xz
nixos-76a0579933da3ed3ea6a39731a8c50e592c3d7e4.zip
Changed back to symbolic links
Diffstat (limited to 'custom/opossum.nix')
l---------[-rw-r--r--]custom/opossum.nix31
1 files changed, 1 insertions, 30 deletions
diff --git a/custom/opossum.nix b/custom/opossum.nix
index ea550a8a..b48ef343 100644..120000
--- a/custom/opossum.nix
+++ b/custom/opossum.nix
@@ -1,30 +1 @@
1# This file was auto-generated by cabal2nix. Please do NOT edit manually! ../opossum/opossum.nix \ No newline at end of file
2
3{ cabal, beuteltier, dataDefault, dyre, exceptions, feed, filepath
4, httpClient, httpClientTls, lenses, mtl, shellMonad, tagged, text
5, time, transformers, hxt, caseInsensitive, attoparsec
6, fetchgit
7}:
8
9cabal.mkDerivation (self: {
10 pname = "opossum";
11 version = "1.4.1";
12 src = fetchgit {
13 url = git://git.yggdrasil.li/opossum;
14 # nix-shell -p nix-prefetch-scripts --command 'nix-prefetch-git git://git.yggdrasil.li/opossum' 2>&1 | grep -E '(git revision|hash) is ' | sed -r 's/git revision is /rev = "/' | sed -r 's/hash is /sha256 = "/' | sed -r 's/$/";/'
15 rev = "f5d384df2a6dff3a7402e51ee5aff58bd6792e6a";
16 sha256 = "8b6e1d6878dce58bfc7cb0c9414a69109c622aae16d4515cf22d72825ae3da5f";
17 };
18 isLibrary = true;
19 isExecutable = true;
20 buildDepends = [
21 beuteltier dataDefault dyre exceptions feed filepath httpClient
22 httpClientTls lenses mtl shellMonad tagged text time transformers
23 hxt caseInsensitive attoparsec
24 ];
25 meta = {
26 description = "A webscraper for beuteltier";
27 license = self.stdenv.lib.licenses.publicDomain;
28 platforms = self.ghc.meta.platforms;
29 };
30})