summaryrefslogtreecommitdiff
path: root/custom/opossum-wrapper.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2015-06-12 19:43:47 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2015-06-12 19:43:47 +0200
commit8fb479ae5ac335e67413189984adaaaed0fbf4db (patch)
tree77359d1cc7b18123ee5d6d0b405fe435865d2620 /custom/opossum-wrapper.nix
parenteb5a39aee4c9f4767f23911495d7a72e5bf27471 (diff)
downloadnixos-8fb479ae5ac335e67413189984adaaaed0fbf4db.tar
nixos-8fb479ae5ac335e67413189984adaaaed0fbf4db.tar.gz
nixos-8fb479ae5ac335e67413189984adaaaed0fbf4db.tar.bz2
nixos-8fb479ae5ac335e67413189984adaaaed0fbf4db.tar.xz
nixos-8fb479ae5ac335e67413189984adaaaed0fbf4db.zip
beuteltiere
Diffstat (limited to 'custom/opossum-wrapper.nix')
-rw-r--r--custom/opossum-wrapper.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/custom/opossum-wrapper.nix b/custom/opossum-wrapper.nix
new file mode 100644
index 00000000..2a2a1bff
--- /dev/null
+++ b/custom/opossum-wrapper.nix
@@ -0,0 +1,20 @@
1{ stdenv
2, ghcWithPackages
3, makeWrapper
4, opossum
5, additionalPackages ? (p: [])
6}:
7
8let
9 myEnv = ghcWithPackages (p: with p; [ beuteltier opossum ] ++ additionalPackages p);
10in stdenv.mkDerivation {
11 name = "opossum-wrapper";
12
13 nativeBuildInputs = [ makeWrapper ];
14
15 buildCommand = ''
16 mkdir -p $out/bin
17 makeWrapper ${opossum}/bin/opossum $out/bin/opossum \
18 --set NIX_GHC ${myEnv}/bin/ghc
19 '';
20}