summaryrefslogtreecommitdiff
path: root/custom/opossum-wrapper.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2015-06-13 15:42:24 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2015-06-13 15:42:24 +0200
commit76a0579933da3ed3ea6a39731a8c50e592c3d7e4 (patch)
tree84ed7eff9019b55ad86f1b733383f96a6e3d5ebd /custom/opossum-wrapper.nix
parent7fdb3c3a45a3b71ea8ccb35e2801eaee9e4044ef (diff)
downloadnixos-76a0579933da3ed3ea6a39731a8c50e592c3d7e4.tar
nixos-76a0579933da3ed3ea6a39731a8c50e592c3d7e4.tar.gz
nixos-76a0579933da3ed3ea6a39731a8c50e592c3d7e4.tar.bz2
nixos-76a0579933da3ed3ea6a39731a8c50e592c3d7e4.tar.xz
nixos-76a0579933da3ed3ea6a39731a8c50e592c3d7e4.zip
Changed back to symbolic links
Diffstat (limited to 'custom/opossum-wrapper.nix')
l---------[-rw-r--r--]custom/opossum-wrapper.nix21
1 files changed, 1 insertions, 20 deletions
diff --git a/custom/opossum-wrapper.nix b/custom/opossum-wrapper.nix
index 2a2a1bff..fe258bb6 100644..120000
--- a/custom/opossum-wrapper.nix
+++ b/custom/opossum-wrapper.nix
@@ -1,20 +1 @@
1{ stdenv ../opossum/wrapper.nix \ No newline at end of file
2, ghcWithPackages
3, makeWrapper
4, opossum
5, additionalPackages ? (p: [])
6}:
7
8let
9 myEnv = ghcWithPackages (p: with p; [ beuteltier opossum ] ++ additionalPackages p);
10in stdenv.mkDerivation {
11 name = "opossum-wrapper";
12
13 nativeBuildInputs = [ makeWrapper ];
14
15 buildCommand = ''
16 mkdir -p $out/bin
17 makeWrapper ${opossum}/bin/opossum $out/bin/opossum \
18 --set NIX_GHC ${myEnv}/bin/ghc
19 '';
20}