summaryrefslogtreecommitdiff
path: root/custom/notify-users.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2018-06-02 18:13:24 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2018-06-02 18:13:24 +0200
commitdea8e06fc0a46b47c2465a2776509040ace64eb7 (patch)
tree342481be58e43d513853cecd642a09dc5954476a /custom/notify-users.nix
parente79f5c73328d7abf540ea55cbbb5a8ef377297a1 (diff)
downloadnixos-dea8e06fc0a46b47c2465a2776509040ace64eb7.tar
nixos-dea8e06fc0a46b47c2465a2776509040ace64eb7.tar.gz
nixos-dea8e06fc0a46b47c2465a2776509040ace64eb7.tar.bz2
nixos-dea8e06fc0a46b47c2465a2776509040ace64eb7.tar.xz
nixos-dea8e06fc0a46b47c2465a2776509040ace64eb7.zip
...
Diffstat (limited to 'custom/notify-users.nix')
-rw-r--r--custom/notify-users.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/custom/notify-users.nix b/custom/notify-users.nix
index ca2d980a..42c45403 100644
--- a/custom/notify-users.nix
+++ b/custom/notify-users.nix
@@ -11,16 +11,15 @@ let
11 11
12 phases = [ "unpackPhase" "buildPhase" "installPhase" ]; 12 phases = [ "unpackPhase" "buildPhase" "installPhase" ];
13 13
14 unpackPhase = ''
15 cp $src notify-user.hs
16 '';
17
18 user = userName; 14 user = userName;
19 home = config.users.users."${userName}".home; 15 home = config.users.users."${userName}".home;
20 16
17 unpackPhase = ''
18 substituteAll $src notify-${userName}.hs
19 '';
20
21 buildPhase = '' 21 buildPhase = ''
22 substituteAllInPlace notify-user.hs 22 ${haskellPackages.ghcWithPackages (p: with p; [ Glob process libnotify getopt-simple containers ])}/bin/ghc -odir . -hidir . notify-${userName}.hs -o notify-${userName}
23 ${haskellPackages.ghcWithPackages (p: with p; [ Glob process libnotify getopt-simple containers ])}/bin/ghc -odir . -hidir . $src -o notify-${userName}
24 ''; 23 '';
25 24
26 installPhase = '' 25 installPhase = ''