diff options
author | Gregor Kleen <pngwjpgh@users.noreply.github.com> | 2016-10-02 16:53:46 +0200 |
---|---|---|
committer | Gregor Kleen <pngwjpgh@users.noreply.github.com> | 2016-10-02 16:53:46 +0200 |
commit | 1166d1a3fc0311a5079256debfb51822d76a045c (patch) | |
tree | 0a4079e7ce4994d9b8d962d1a0562a5af899c4a6 /custom/notify-user.nix | |
parent | 6bee5a3331cf7fadab2aa30b6fbe43dd9ef7be24 (diff) | |
download | nixos-1166d1a3fc0311a5079256debfb51822d76a045c.tar nixos-1166d1a3fc0311a5079256debfb51822d76a045c.tar.gz nixos-1166d1a3fc0311a5079256debfb51822d76a045c.tar.bz2 nixos-1166d1a3fc0311a5079256debfb51822d76a045c.tar.xz nixos-1166d1a3fc0311a5079256debfb51822d76a045c.zip |
read instance
Diffstat (limited to 'custom/notify-user.nix')
-rw-r--r-- | custom/notify-user.nix | 4 |
1 files changed, 3 insertions, 1 deletions
diff --git a/custom/notify-user.nix b/custom/notify-user.nix index c2ad3472..e9e98ddc 100644 --- a/custom/notify-user.nix +++ b/custom/notify-user.nix | |||
@@ -7,7 +7,7 @@ | |||
7 | stdenv.mkDerivation { | 7 | stdenv.mkDerivation { |
8 | name = ''notify-${user}''; | 8 | name = ''notify-${user}''; |
9 | src = writeTextFile { name = ''notify-${user}.hs''; text = '' | 9 | src = writeTextFile { name = ''notify-${user}.hs''; text = '' |
10 | {-# LANGUAGE ViewPatterns #-} | 10 | {-# LANGUAGE ViewPatterns, StandaloneDeriving #-} |
11 | 11 | ||
12 | import System.FilePath.Glob (glob) | 12 | import System.FilePath.Glob (glob) |
13 | import System.Environment (setEnv, getArgs) | 13 | import System.Environment (setEnv, getArgs) |
@@ -29,6 +29,8 @@ stdenv.mkDerivation { | |||
29 | import Data.Maybe | 29 | import Data.Maybe |
30 | import Text.Read (readMaybe) | 30 | import Text.Read (readMaybe) |
31 | 31 | ||
32 | deriving instance Read Notify.Urgency | ||
33 | |||
32 | main = do | 34 | main = do |
33 | envFiles <- glob "/home/${user}/.dbus/session-bus/*" | 35 | envFiles <- glob "/home/${user}/.dbus/session-bus/*" |
34 | forM_ envFiles $ \envFile -> do | 36 | forM_ envFiles $ \envFile -> do |