summaryrefslogtreecommitdiff
path: root/custom/dotfiles.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2015-07-03 22:42:08 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2015-07-03 22:42:08 +0200
commit023b9845370c1e10eba3679034e527ff9efdc644 (patch)
treec54471ac8d204f158267a7f578b633b0600702c2 /custom/dotfiles.nix
parentf2440a30e085f9e1b368438fde07d3b04e7139e6 (diff)
downloadnixos-023b9845370c1e10eba3679034e527ff9efdc644.tar
nixos-023b9845370c1e10eba3679034e527ff9efdc644.tar.gz
nixos-023b9845370c1e10eba3679034e527ff9efdc644.tar.bz2
nixos-023b9845370c1e10eba3679034e527ff9efdc644.tar.xz
nixos-023b9845370c1e10eba3679034e527ff9efdc644.zip
no dereferencing in chown
Diffstat (limited to 'custom/dotfiles.nix')
-rw-r--r--custom/dotfiles.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/custom/dotfiles.nix b/custom/dotfiles.nix
index 08952c39..6b55dd55 100644
--- a/custom/dotfiles.nix
+++ b/custom/dotfiles.nix
@@ -17,7 +17,7 @@ let
17 cd ${dotfiles} 17 cd ${dotfiles}
18 ${findutils}/bin/find . -type d -print0 | ${findutils}/bin/xargs -0 -I '{}' -- ${coreutils}/install -o ${name.owner} -g ${name.group} -d "${name.dir}/{}" 18 ${findutils}/bin/find . -type d -print0 | ${findutils}/bin/xargs -0 -I '{}' -- ${coreutils}/install -o ${name.owner} -g ${name.group} -d "${name.dir}/{}"
19 ${findutils}/bin/find . -type f -print0 | ${findutils}/bin/xargs -0 -I '{}' -- ln -s -f "${dotfiles}/{}" "${name.dir}/{}" 19 ${findutils}/bin/find . -type f -print0 | ${findutils}/bin/xargs -0 -I '{}' -- ln -s -f "${dotfiles}/{}" "${name.dir}/{}"
20 ${findutils}/bin/find . -type f -print0 | ${findutils}/bin/xargs -0 -I '{}' -- chown "${name.owner}:${name.group}" "${name.dir}/{}" 20 ${findutils}/bin/find . -type f -print0 | ${findutils}/bin/xargs -0 -I '{}' -- chown -h "${name.owner}:${name.group}" "${name.dir}/{}"
21 ''; 21 '';
22 }; 22 };
23in 23in