summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2018-04-16 13:20:51 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2018-04-16 13:20:51 +0200
commitf59c0553147c02b4c925edf8c99596edbd1079e8 (patch)
tree7f4b37e5f0768fe114fd63e7bbd340d51afe60f2 /bragi.nix
parentf8d562c8267635fe3a82b404f46626472ec34283 (diff)
downloadnixos-f59c0553147c02b4c925edf8c99596edbd1079e8.tar
nixos-f59c0553147c02b4c925edf8c99596edbd1079e8.tar.gz
nixos-f59c0553147c02b4c925edf8c99596edbd1079e8.tar.bz2
nixos-f59c0553147c02b4c925edf8c99596edbd1079e8.tar.xz
nixos-f59c0553147c02b4c925edf8c99596edbd1079e8.zip
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/bragi.nix b/bragi.nix
index b5c0d82a..59bcbd1e 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -89,7 +89,6 @@ in rec {
89 encoding = haskell.lib.overrideCabal encoding ( oldAttrs: { 89 encoding = haskell.lib.overrideCabal encoding ( oldAttrs: {
90 src = fetchFromGitHub { owner = "pngwjpgh"; repo = "encoding"; rev = "extended-version-bounds"; sha256 = "0pzxixp384a1ywzj56pl7xc4ln7i9x6mq8spqjwcs80y0pgfpp9s"; }; 90 src = fetchFromGitHub { owner = "pngwjpgh"; repo = "encoding"; rev = "extended-version-bounds"; sha256 = "0pzxixp384a1ywzj56pl7xc4ln7i9x6mq8spqjwcs80y0pgfpp9s"; };
91 }); 91 });
92 trivmix = self.callPackage ./custom/trivmix/trivmix.nix {};
93 inherit 92 inherit
94 (lib.mapAttrs (name: haskell.lib.dontCheck) super) 93 (lib.mapAttrs (name: haskell.lib.dontCheck) super)
95 Glob filelock hedgehog; 94 Glob filelock hedgehog;
@@ -103,7 +102,7 @@ in rec {
103 102
104 mpd = mpd.override { gmeSupport = false; pulseaudioSupport = false; }; 103 mpd = mpd.override { gmeSupport = false; pulseaudioSupport = false; };
105 104
106 inherit (pkgs.haskellPackages) trivmix thermoprint-server thermoprint-webgui tprint; 105 inherit (pkgs.haskellPackages) thermoprint-server thermoprint-webgui tprint;
107 }; 106 };
108 107
109 allowUnfree = true; 108 allowUnfree = true;
@@ -116,7 +115,6 @@ in rec {
116 tmux 115 tmux
117 nfs-utils 116 nfs-utils
118 jack2Full 117 jack2Full
119 trivmix
120 zsh 118 zsh
121 tprint 119 tprint
122 samba 120 samba
@@ -311,13 +309,13 @@ in rec {
311 systemd.services."thermoprint" = { 309 systemd.services."thermoprint" = {
312 environment = { 310 environment = {
313 THERMOPRINT_CONFIG = ./bragi/thermoprint-server; 311 THERMOPRINT_CONFIG = ./bragi/thermoprint-server;
314 THERMOPRINT_CACHE = ''${users.extraUsers."thermoprint".home}/dyre''; 312 THERMOPRINT_CACHE = "${users.extraUsers."thermoprint".home}/dyre";
315 }; 313 };
316 requires = [ "postgresql.service" ]; 314 requires = [ "postgresql.service" ];
317 wantedBy = [ "default.target" ]; 315 wantedBy = [ "default.target" ];
318 serviceConfig = { 316 serviceConfig = {
319 Type = "simple"; 317 Type = "simple";
320 ExecStart = ''${pkgs.thermoprint-server}/bin/thermoprint-server --force-reconf''; 318 ExecStart = "${pkgs.thermoprint-server}/bin/thermoprint-server --force-reconf";
321 User = users.extraUsers."thermoprint".name; 319 User = users.extraUsers."thermoprint".name;
322 Group = users.extraUsers."thermoprint".group; 320 Group = users.extraUsers."thermoprint".group;
323 WorkingDirectory = "~"; 321 WorkingDirectory = "~";