summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2018-04-15 17:12:07 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2018-04-15 17:12:07 +0200
commit901c3a85932cfe5951dc91eb186cdad73b9ef18c (patch)
tree4c3004dbb9ac74c828bb567b0b7ea0be137723eb /bragi.nix
parent6fefa0dd4777322f7bc0b111cd02988c8c9754ee (diff)
downloadnixos-901c3a85932cfe5951dc91eb186cdad73b9ef18c.tar
nixos-901c3a85932cfe5951dc91eb186cdad73b9ef18c.tar.gz
nixos-901c3a85932cfe5951dc91eb186cdad73b9ef18c.tar.bz2
nixos-901c3a85932cfe5951dc91eb186cdad73b9ef18c.tar.xz
nixos-901c3a85932cfe5951dc91eb186cdad73b9ef18c.zip
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix20
1 files changed, 14 insertions, 6 deletions
diff --git a/bragi.nix b/bragi.nix
index a46f8378..e8489353 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -30,14 +30,22 @@ in rec {
30 br0.interfaces = [ "enp1s0" "enp2s0" "enp3s0" "wlp4s0" ]; 30 br0.interfaces = [ "enp1s0" "enp2s0" "enp3s0" "wlp4s0" ];
31 }; 31 };
32 32
33 interfaces = (lib.genAttrs ["enp1s0" "enp2s0" "enp3s0"] { 33 interfaces.enp1s0 = {
34 proxyARP = true; 34 proxyARP = true;
35 useDHCP = false; 35 useDHCP = false;
36 }) // { 36 };
37 wlp4s0 = { 37 interfaces.enp2s0 = {
38 proxyARP = true; 38 proxyARP = true;
39 useDHCP = true; 39 useDHCP = false;
40 }; 40 };
41 interfaces.enp3s0 = {
42 proxyARP = true;
43 useDHCP = false;
44 };
45
46 interfaces.wlp4s0 = {
47 proxyARP = true;
48 useDHCP = true;
41 }; 49 };
42 50
43 firewall = { 51 firewall = {