summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
authorGregor Kleen <pngwjpgh@users.noreply.github.com>2016-07-17 20:20:46 +0200
committerGregor Kleen <pngwjpgh@users.noreply.github.com>2016-07-17 20:20:46 +0200
commit837b66f8fc285b9adf4ce1e12eaac6bbcf458a03 (patch)
tree1caa855d4ecf5d2f95fd3723290ee7be291e31d5 /bragi.nix
parent2e1e618cec51e70c059796906e3a1b32c3fdcb86 (diff)
downloadnixos-837b66f8fc285b9adf4ce1e12eaac6bbcf458a03.tar
nixos-837b66f8fc285b9adf4ce1e12eaac6bbcf458a03.tar.gz
nixos-837b66f8fc285b9adf4ce1e12eaac6bbcf458a03.tar.bz2
nixos-837b66f8fc285b9adf4ce1e12eaac6bbcf458a03.tar.xz
nixos-837b66f8fc285b9adf4ce1e12eaac6bbcf458a03.zip
config errors
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/bragi.nix b/bragi.nix
index 50f71dc3..d3c04f5a 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -300,7 +300,7 @@ in rec {
300 runSqlite :: ReaderT ConnectionPool (LoggingT IO) a -> IO a 300 runSqlite :: ReaderT ConnectionPool (LoggingT IO) a -> IO a
301 runSqlite = runStderrLoggingT . withSqlitePool "${users.extraUsers."thermoprint".home}/thermoprint.sqlite" 1 . runReaderT 301 runSqlite = runStderrLoggingT . withSqlitePool "${users.extraUsers."thermoprint".home}/thermoprint.sqlite" 1 . runReaderT
302 302
303 printers = [ (pure $ genericPrint "/dev/usb/lp0", def) 303 printers = [ (pure $ genericPrint "/dev/usb/lp0", def :: QMConfig (ResourceT (ReaderT ConnectionPool (LoggingT IO))))
304 ] 304 ]
305 305
306 queueManagers _ = QMConfig 306 queueManagers _ = QMConfig
@@ -319,6 +319,7 @@ in rec {
319 THERMOPRINT_CONFIG = "/etc/thermoprint-server"; 319 THERMOPRINT_CONFIG = "/etc/thermoprint-server";
320 THERMOPRINT_CACHE = ''${users.extraUsers."thermoprint".home}/dyre''; 320 THERMOPRINT_CACHE = ''${users.extraUsers."thermoprint".home}/dyre'';
321 }; 321 };
322 wantedBy = [ "default.target" ];
322 serviceConfig = { 323 serviceConfig = {
323 Type = "simple"; 324 Type = "simple";
324 ExecStart = ''${pkgs.thermoprint-server}/bin/thermoprint-server''; 325 ExecStart = ''${pkgs.thermoprint-server}/bin/thermoprint-server'';
@@ -328,6 +329,7 @@ in rec {
328 }; 329 };
329 330
330 systemd.services."thermoprint-webgui" = { 331 systemd.services."thermoprint-webgui" = {
332 wantedBy = [ "default.target" ];
331 serviceConfig = { 333 serviceConfig = {
332 Type = "simple"; 334 Type = "simple";
333 ExecStart = ''${pkgs.thermoprint-webgui}/bin/thermoprint-webgui -P 8080 -A localhost -a "*" -p 8081''; 335 ExecStart = ''${pkgs.thermoprint-webgui}/bin/thermoprint-webgui -P 8080 -A localhost -a "*" -p 8081'';