diff options
author | Gregor Kleen <gkleen@yggdrasil.li> | 2021-01-03 01:14:47 +0100 |
---|---|---|
committer | Gregor Kleen <gkleen@yggdrasil.li> | 2021-01-03 16:21:34 +0100 |
commit | 392e6768f9f60c761b65f8774c1667ab8d00f230 (patch) | |
tree | e84d0439a01402e3bd85a627c6594526f1d0a8ed /accounts/gkleen@sif/xmobar/shell.nix | |
parent | 4a3d2a8ddaf4e546df360656bc54b2947bdb890b (diff) | |
download | nixos-392e6768f9f60c761b65f8774c1667ab8d00f230.tar nixos-392e6768f9f60c761b65f8774c1667ab8d00f230.tar.gz nixos-392e6768f9f60c761b65f8774c1667ab8d00f230.tar.bz2 nixos-392e6768f9f60c761b65f8774c1667ab8d00f230.tar.xz nixos-392e6768f9f60c761b65f8774c1667ab8d00f230.zip |
gkleen@sif: systemd
Diffstat (limited to 'accounts/gkleen@sif/xmobar/shell.nix')
-rw-r--r-- | accounts/gkleen@sif/xmobar/shell.nix | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/accounts/gkleen@sif/xmobar/shell.nix b/accounts/gkleen@sif/xmobar/shell.nix new file mode 100644 index 00000000..18188e78 --- /dev/null +++ b/accounts/gkleen@sif/xmobar/shell.nix | |||
@@ -0,0 +1,28 @@ | |||
1 | { nixpkgs ? import ./nixpkgs.nix {} }: | ||
2 | |||
3 | let | ||
4 | inherit (nixpkgs {}) pkgs; | ||
5 | haskellPackages = import ./stackage.nix { inherit nixpkgs; }; | ||
6 | |||
7 | drv = haskellPackages.callPackage ./xmobar-yggdrasil.nix {}; | ||
8 | override = oldAttrs: { | ||
9 | nativeBuildInputs = oldAttrs.nativeBuildInputs ++ (with pkgs; []) ++ (with haskellPackages; [ stack cabal-install cabal2nix ]); | ||
10 | shellHook = '' | ||
11 | export PROMPT_INFO="${oldAttrs.name}" | ||
12 | |||
13 | if [ -n "$ZSH_VERSION" ]; then | ||
14 | autoload -U +X compinit && compinit | ||
15 | autoload -U +X bashcompinit && bashcompinit | ||
16 | fi | ||
17 | eval "$(stack --bash-completion-script stack)" | ||
18 | |||
19 | ${oldAttrs.shellHook} | ||
20 | ''; | ||
21 | }; | ||
22 | |||
23 | dummy = pkgs.stdenv.mkDerivation { | ||
24 | name = "interactive-xmobar-environment"; | ||
25 | shellHook = ""; | ||
26 | }; | ||
27 | in pkgs.stdenv.lib.overrideDerivation dummy override | ||
28 | #pkgs.stdenv.lib.overrideDerivation drv.env override | ||