diff options
author | Gregor Kleen <gkleen@yggdrasil.li> | 2025-01-28 10:59:42 +0100 |
---|---|---|
committer | Gregor Kleen <gkleen@yggdrasil.li> | 2025-01-28 10:59:42 +0100 |
commit | 3315faabe0201f9a209235ef5291f02076dbcbac (patch) | |
tree | 19aec52c5efb3258b005885073a8dbe9afc0b52c /accounts/gkleen@sif/niri/swayosd.nix | |
parent | ae7a3dcdf7dd30930c458e4b5210d9427425e4eb (diff) | |
download | nixos-3315faabe0201f9a209235ef5291f02076dbcbac.tar nixos-3315faabe0201f9a209235ef5291f02076dbcbac.tar.gz nixos-3315faabe0201f9a209235ef5291f02076dbcbac.tar.bz2 nixos-3315faabe0201f9a209235ef5291f02076dbcbac.tar.xz nixos-3315faabe0201f9a209235ef5291f02076dbcbac.zip |
...
Diffstat (limited to 'accounts/gkleen@sif/niri/swayosd.nix')
-rw-r--r-- | accounts/gkleen@sif/niri/swayosd.nix | 53 |
1 files changed, 53 insertions, 0 deletions
diff --git a/accounts/gkleen@sif/niri/swayosd.nix b/accounts/gkleen@sif/niri/swayosd.nix new file mode 100644 index 00000000..48899c10 --- /dev/null +++ b/accounts/gkleen@sif/niri/swayosd.nix | |||
@@ -0,0 +1,53 @@ | |||
1 | { pkgs, ... }: | ||
2 | { | ||
3 | config = { | ||
4 | services.swayosd = { | ||
5 | enable = true; | ||
6 | topMargin = 0.0344; | ||
7 | stylePath = pkgs.runCommand "style.css" { | ||
8 | src = pkgs.writeText "style.scss" '' | ||
9 | window#osd { | ||
10 | padding: 12px 20px; | ||
11 | border-radius: 999px; | ||
12 | border: none; | ||
13 | background: rgba(0, 0, 0, 0.66); | ||
14 | |||
15 | #container { | ||
16 | margin: 16px; | ||
17 | } | ||
18 | |||
19 | image, | ||
20 | label { | ||
21 | color: rgb(255, 255, 255); | ||
22 | } | ||
23 | |||
24 | progressbar:disabled, | ||
25 | image:disabled { | ||
26 | opacity: 0.5; | ||
27 | } | ||
28 | |||
29 | progressbar { | ||
30 | min-height: 6px; | ||
31 | border-radius: 999px; | ||
32 | background: transparent; | ||
33 | border: none; | ||
34 | } | ||
35 | trough { | ||
36 | min-height: inherit; | ||
37 | border-radius: inherit; | ||
38 | border: none; | ||
39 | background: rgba(255, 255, 255, 0.5); | ||
40 | } | ||
41 | progress { | ||
42 | min-height: inherit; | ||
43 | border-radius: inherit; | ||
44 | border: none; | ||
45 | background: rgb(255, 255, 255); | ||
46 | } | ||
47 | } | ||
48 | ''; | ||
49 | buildInputs = with pkgs; [sass]; | ||
50 | } "scss -C --sourcemap=none $src $out"; | ||
51 | }; | ||
52 | }; | ||
53 | } | ||