summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/niri/default.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2025-04-25 14:52:15 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2025-04-25 14:52:15 +0200
commit740081d9eecff224fe5aa398000f0dcb72ff89b5 (patch)
tree1fb23f7d07e1fef673e3d9106c1450124a11119c /accounts/gkleen@sif/niri/default.nix
parente85f955fbcf4e0541a0c7985deab5e59c37164a7 (diff)
downloadnixos-740081d9eecff224fe5aa398000f0dcb72ff89b5.tar
nixos-740081d9eecff224fe5aa398000f0dcb72ff89b5.tar.gz
nixos-740081d9eecff224fe5aa398000f0dcb72ff89b5.tar.bz2
nixos-740081d9eecff224fe5aa398000f0dcb72ff89b5.tar.xz
nixos-740081d9eecff224fe5aa398000f0dcb72ff89b5.zip
bump
Diffstat (limited to 'accounts/gkleen@sif/niri/default.nix')
-rw-r--r--accounts/gkleen@sif/niri/default.nix4
1 files changed, 0 insertions, 4 deletions
diff --git a/accounts/gkleen@sif/niri/default.nix b/accounts/gkleen@sif/niri/default.nix
index b5347d6f..0e25fc95 100644
--- a/accounts/gkleen@sif/niri/default.nix
+++ b/accounts/gkleen@sif/niri/default.nix
@@ -273,8 +273,6 @@ in {
273 workspaces = list() 273 workspaces = list()
274 274
275 def focus_workspace(output, workspace): 275 def focus_workspace(output, workspace):
276 global workspace_history, history_lock
277
278 with history_lock: 276 with history_lock:
279 workspace_history[output] = [workspace] + [ws for ws in workspace_history[output] if ws != workspace] # noqa: E501 277 workspace_history[output] = [workspace] + [ws for ws in workspace_history[output] if ws != workspace] # noqa: E501
280 print(json.dumps(workspace_history), file=sys.stderr) 278 print(json.dumps(workspace_history), file=sys.stderr)
@@ -299,8 +297,6 @@ in {
299 297
300 class RequestHandler(StreamRequestHandler): 298 class RequestHandler(StreamRequestHandler):
301 def handle(self): 299 def handle(self):
302 global workspace_history, history_lock
303
304 with detaching(TextIOWrapper(self.wfile, encoding='utf-8', write_through=True)) as out: # noqa: E501 300 with detaching(TextIOWrapper(self.wfile, encoding='utf-8', write_through=True)) as out: # noqa: E501
305 with history_lock: 301 with history_lock:
306 json.dump(workspace_history, out) 302 json.dump(workspace_history, out)