summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 57fb472..3da569e 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,7 @@
1{ pkgs ? (import <nixpkgs> {}) 1{ pkgs ? (import <nixpkgs> {})
2}: 2}:
3 3
4pkgs.stdenv.mkDerivation { 4pkgs.stdenv.mkDerivation rec {
5 name = "uni-env"; 5 name = "uni-env";
6 buildInputs = [ pkgs.haskellPackages.pandoc 6 buildInputs = [ pkgs.haskellPackages.pandoc
7 pkgs.gup 7 pkgs.gup
@@ -15,4 +15,7 @@ pkgs.stdenv.mkDerivation {
15 with p; [ yesod yesod-bin 15 with p; [ yesod yesod-bin
16 ])) 16 ]))
17 ]; 17 ];
18 shellHook = ''
19 export PROMPT_INFO="${name}"
20 '';
18} 21}