summaryrefslogtreecommitdiff
path: root/ss2017/cryptography/Sheet01/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2017-05-02 14:39:57 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2017-05-02 14:39:57 +0200
commit47706c9239192b1298eef8b2cc0ead7a60262751 (patch)
treef763a163666631666e528027d0d579ab9fe57a8d /ss2017/cryptography/Sheet01/shell.nix
parent3073ee25e150388a660a352d4ab67dc583009604 (diff)
downloaduni-47706c9239192b1298eef8b2cc0ead7a60262751.tar
uni-47706c9239192b1298eef8b2cc0ead7a60262751.tar.gz
uni-47706c9239192b1298eef8b2cc0ead7a60262751.tar.bz2
uni-47706c9239192b1298eef8b2cc0ead7a60262751.tar.xz
uni-47706c9239192b1298eef8b2cc0ead7a60262751.zip
crypto sheet01
Diffstat (limited to 'ss2017/cryptography/Sheet01/shell.nix')
-rw-r--r--ss2017/cryptography/Sheet01/shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/ss2017/cryptography/Sheet01/shell.nix b/ss2017/cryptography/Sheet01/shell.nix
new file mode 100644
index 0000000..5f84e18
--- /dev/null
+++ b/ss2017/cryptography/Sheet01/shell.nix
@@ -0,0 +1,13 @@
1{ pkgs ? (import <nixpkgs> {})
2}:
3
4pkgs.stdenv.mkDerivation rec {
5 name = "substitution-env";
6 buildInputs = [ (pkgs.haskellPackages.ghcWithPackages (p:
7 with p; [ case-insensitive containers
8 ]))
9 ];
10 shellHook = ''
11 export PROMPT_INFO="${name}"
12 '';
13}