summaryrefslogtreecommitdiff
path: root/trivstream.nix
diff options
context:
space:
mode:
Diffstat (limited to 'trivstream.nix')
-rw-r--r--trivstream.nix14
1 files changed, 11 insertions, 3 deletions
diff --git a/trivstream.nix b/trivstream.nix
index 2521a88..7e8c872 100644
--- a/trivstream.nix
+++ b/trivstream.nix
@@ -1,11 +1,19 @@
1{ mkDerivation, base, stdenv }: 1{ mkDerivation, base, cereal, cereal-conduit, conduit
2, conduit-extra, data-default-class, gitrev, jack, lens, mtl
3, network, optparse-applicative, pulse-simple, socket-activation
4, stdenv, transformers
5}:
2mkDerivation { 6mkDerivation {
3 pname = "trivstream"; 7 pname = "trivstream";
4 version = "0.0.0"; 8 version = "0.0.0";
5 src = ./.; 9 src = ./.;
6 isLibrary = false; 10 isLibrary = false;
7 isExecutable = true; 11 isExecutable = true;
8 executableHaskellDepends = [ base ]; 12 executableHaskellDepends = [
9 description = "A trivial client & server for streaming audio over udp between pulseaudio & jack"; 13 base cereal cereal-conduit conduit conduit-extra data-default-class
14 gitrev jack lens mtl network optparse-applicative pulse-simple
15 socket-activation transformers
16 ];
17 description = "A trivial client & server for streaming audio between pulseaudio and jack over udp/tcp";
10 license = stdenv.lib.licenses.gpl3; 18 license = stdenv.lib.licenses.gpl3;
11} 19}