summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <aethoago@141.li>2017-01-26 15:02:04 +0100
committerGregor Kleen <aethoago@141.li>2017-01-26 15:02:04 +0100
commit443f196032530cbd9eb39606c2daf4294460a44b (patch)
tree373c0ebddfc5483d673cd8509959220dba1858b1 /shell.nix
downloadpostdelay-443f196032530cbd9eb39606c2daf4294460a44b.tar
postdelay-443f196032530cbd9eb39606c2daf4294460a44b.tar.gz
postdelay-443f196032530cbd9eb39606c2daf4294460a44b.tar.bz2
postdelay-443f196032530cbd9eb39606c2daf4294460a44b.tar.xz
postdelay-443f196032530cbd9eb39606c2daf4294460a44b.zip
Project skeleton
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..a4274e7
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,9 @@
1{ pkgs ? (import <nixpkgs> {})
2}:
3
4pkgs.lib.overrideDerivation (pkgs.haskellPackages.callPackage ./default.nix {}) (oldArgs: {
5 buildInputs = with pkgs; [ cabal2nix gup ];
6 shellHook = ''
7 export PROMPT_INFO=${oldArgs.name}
8 '';
9})