summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2016-04-05 23:48:15 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2016-04-05 23:48:15 +0200
commit60a5da37a6f25d25963c9cbd2750ff16db2361a2 (patch)
tree7a5e72c21416543420a75e1855363907547ddd9d /shell.nix
downloadevents-60a5da37a6f25d25963c9cbd2750ff16db2361a2.tar
events-60a5da37a6f25d25963c9cbd2750ff16db2361a2.tar.gz
events-60a5da37a6f25d25963c9cbd2750ff16db2361a2.tar.bz2
events-60a5da37a6f25d25963c9cbd2750ff16db2361a2.tar.xz
events-60a5da37a6f25d25963c9cbd2750ff16db2361a2.zip
Framework
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..684f721
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,16 @@
1{ pkgs ? (import <nixpkgs> {})
2, haskellPackages ? (import ./default.nix { inherit pkgs; }).haskellPackages
3}:
4
5let
6 ghc = haskellPackages.ghcWithPackages (ps: payload ++ (with ps; [ hlint cabal2nix cabal-install ]));
7 payload = builtins.attrValues (import ./default.nix {});
8in pkgs.stdenv.mkDerivation rec {
9 bareName = "event";
10 name = "${bareName}-env";
11 buildInputs = [ ghc ];
12 shellHook = ''
13 eval $(egrep ^export ${ghc}/bin/ghc)
14 export PROMPT_INFO="${name}"
15 '';
16}