summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..c1baba7
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,11 @@
1{ pkgs ? (import <nixpkgs> {})
2}:
3
4pkgs.stdenv.mkDerivation rec {
5 name = "dirty-haskell";
6 buildInputs = [ (import ./default.nix).dirty-haskell
7 ];
8 shellHook = ''
9 export PROMPT_INFO=${name}
10 '';
11}