summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/shell.nix b/shell.nix
index b2b6842..eb6bd17 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,13 +1,13 @@
1{ nixpkgs ? import <nixpkgs> {}, compiler ? "default" }: 1{ nixpkgs ? import <nixpkgs> {}, compiler ? null }:
2 2
3let 3let
4 inherit (nixpkgs) pkgs; 4 inherit (nixpkgs) pkgs;
5 5
6 haskellPackages = if compiler == "default" 6 haskellPackages = if compiler == null
7 then pkgs.haskellPackages 7 then pkgs.haskellPackages
8 else pkgs.haskell.packages.${compiler}; 8 else pkgs.haskell.packages."${compiler}";
9 9
10 drv = haskellPackages.callPackage ./bar.nix {}; 10 drv = import ./default.nix {};
11in 11in
12 pkgs.stdenv.lib.overrideDerivation drv.env (oldAttrs: { 12 pkgs.stdenv.lib.overrideDerivation drv.env (oldAttrs: {
13 nativeBuildInputs = oldAttrs.nativeBuildInputs ++ (with pkgs; [ cabal2nix gup postgresql ]) ++ (with haskellPackages; [ hlint stack yesod-bin alex ]); 13 nativeBuildInputs = oldAttrs.nativeBuildInputs ++ (with pkgs; [ cabal2nix gup postgresql ]) ++ (with haskellPackages; [ hlint stack yesod-bin alex ]);