summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 237d7e9..33f1e76 100644
--- a/flake.nix
+++ b/flake.nix
@@ -101,10 +101,10 @@
101 phases = [ "unpackPhase" "patchPhase" "buildPhase" "installPhase" ]; 101 phases = [ "unpackPhase" "patchPhase" "buildPhase" "installPhase" ];
102 patchPhase = let 102 patchPhase = let
103 feedsConf = pkgs.writeText "feeds.conf" '' 103 feedsConf = pkgs.writeText "feeds.conf" ''
104 src-link packages ${inputs.openwrt-packages} 104 src-cpy packages ${inputs.openwrt-packages}
105 src-link luci ${inputs.openwrt-luci} 105 src-cpy luci ${inputs.openwrt-luci}
106 src-link routing ${inputs.openwrt-routing} 106 src-cpy routing ${inputs.openwrt-routing}
107 src-link telephony ${inputs.openwrt-telephony} 107 src-cpy telephony ${inputs.openwrt-telephony}
108 ''; 108 '';
109 in '' 109 in ''
110 rm feeds.conf.default 110 rm feeds.conf.default
@@ -157,7 +157,7 @@
157 ${pkgs.rsync}/bin/rsync --chmod=u+wX -rlptD --exclude /tmp --exclude /build_dir --exclude /bin --exclude /staging_dir ${openwrtWithPackages}/. ${./files}/. ./. 157 ${pkgs.rsync}/bin/rsync --chmod=u+wX -rlptD --exclude /tmp --exclude /build_dir --exclude /bin --exclude /staging_dir ${openwrtWithPackages}/. ${./files}/. ./.
158 158
159 patchDir=$(mktemp -d -t patches.XXXXXXXXXX) 159 patchDir=$(mktemp -d -t patches.XXXXXXXXXX)
160 ${pkgs.rsync}/bin/rsync --chmod=u+wX -rlptD ${./patches}/. "$patchDir/." 160 ${pkgs.rsync}/bin/rsync --chmod=u+wX -rlptD ${./patches}/. "''${patchDir}/."
161 161
162 while IFS= read -r -d $'\0' sopsFile; do 162 while IFS= read -r -d $'\0' sopsFile; do
163 ${pkgs.sops}/bin/sops --output="''${sopsFile%.sops}" --decrypt "''${sopsFile}" 163 ${pkgs.sops}/bin/sops --output="''${sopsFile%.sops}" --decrypt "''${sopsFile}"