summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2022-01-06 08:51:50 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2022-01-06 08:51:50 +0100
commit6f97ed78ab478f7502ea078f1d9be5f06ebfebf7 (patch)
tree8e31f4d3aac91b170dbe13d1fc1df03e533d997c /flake.nix
parentb802fcbe602accf1845bb63603f8b9f0c5d607c1 (diff)
downloadap01-6f97ed78ab478f7502ea078f1d9be5f06ebfebf7.tar
ap01-6f97ed78ab478f7502ea078f1d9be5f06ebfebf7.tar.gz
ap01-6f97ed78ab478f7502ea078f1d9be5f06ebfebf7.tar.bz2
ap01-6f97ed78ab478f7502ea078f1d9be5f06ebfebf7.tar.xz
ap01-6f97ed78ab478f7502ea078f1d9be5f06ebfebf7.zip
...
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 98760a6..6a46fa0 100644
--- a/flake.nix
+++ b/flake.nix
@@ -126,7 +126,7 @@
126 set -ex 126 set -ex
127 127
128 function unpackPhase() { 128 function unpackPhase() {
129 ${pkgs.rsync}/bin/rsync --chmod=u+wX -rlptD --exclude /tmp --exclude /build_dir --exclude /bin ${openwrtWithPackages}/. ${./files}/. ./. 129 ${pkgs.rsync}/bin/rsync --chmod=u+wX -rlptD --exclude /tmp --exclude /build_dir --exclude /bin --exclude /staging_dir ${openwrtWithPackages}/. ${./files}/. ./.
130 130
131 patchDir=$(mktemp -d -t patches.XXXXXXXXXX) 131 patchDir=$(mktemp -d -t patches.XXXXXXXXXX)
132 ${pkgs.rsync}/bin/rsync --chmod=u+wX -rlptD ${./patches}/. "$patchDir/." 132 ${pkgs.rsync}/bin/rsync --chmod=u+wX -rlptD ${./patches}/. "$patchDir/."
@@ -134,9 +134,9 @@
134 while IFS= read -r -d $'\0' sopsFile; do 134 while IFS= read -r -d $'\0' sopsFile; do
135 ${pkgs.sops}/bin/sops --output="''${sopsFile%.sops}" --decrypt "''${sopsFile}" 135 ${pkgs.sops}/bin/sops --output="''${sopsFile%.sops}" --decrypt "''${sopsFile}"
136 rm "''${sopsFile}" 136 rm "''${sopsFile}"
137 done < <(find ./. "$patchDir" -not \( \( -path ./tmp -a -prune \) -o \( -path ./build_dir -a -prune \) -o \( -path ./bin -a -prune \) -o \( -path ./staging_dir -a -prune \) \) -a \( -type f -a -name '*.sops' -a -print0 \)) 137 done < <(find . "$patchDir" -not \( \( -path ./tmp -o -path ./build_dir -o -path ./bin -o -path ./staging_dir \) -a -prune \) -a \( -type f -a -name '*.sops' -a -print0 \))
138 138
139 while IFS= read -r -d $'\0' patchFile; do 139 while IFS= read -r -d $'\0' patchFile; do.
140 patch -p1 --batch <$patchFile 140 patch -p1 --batch <$patchFile
141 done < <(find "$patchDir" -type f -name '*.patch' -print0) 141 done < <(find "$patchDir" -type f -name '*.patch' -print0)
142 } 142 }