summaryrefslogtreecommitdiff
path: root/nix/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/module.nix')
-rw-r--r--nix/module.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nix/module.nix b/nix/module.nix
index edc9bfb..40082b1 100644
--- a/nix/module.nix
+++ b/nix/module.nix
@@ -45,11 +45,17 @@ in {
45 type = with types; listOf (submodule dirConfig); 45 type = with types; listOf (submodule dirConfig);
46 default = []; 46 default = [];
47 }; 47 };
48
49 programs.recv.enable = mkEnableOption "the ‘recv’ program";
48 }; 50 };
49 51
50 config = { 52 config = {
51 nixpkgs.overlays = [ (import ./default.nix) ]; 53 nixpkgs.overlays = [ (import ./default.nix) ];
52 54
53 systemd.services = listToAttrs (map dirService config.services.rollingDirectories); 55 systemd.services = listToAttrs (map dirService config.services.rollingDirectories);
56
57 security.wrappers = mkIf config.programs.recv.enable {
58 recv.source = "${pkgs.recv}/bin/recv";
59 };
54 }; 60 };
55} 61}