aboutsummaryrefslogtreecommitdiff
path: root/server/thermoprint-server.nix
diff options
context:
space:
mode:
Diffstat (limited to 'server/thermoprint-server.nix')
-rw-r--r--server/thermoprint-server.nix20
1 files changed, 11 insertions, 9 deletions
diff --git a/server/thermoprint-server.nix b/server/thermoprint-server.nix
index f472cbc..69ecd2f 100644
--- a/server/thermoprint-server.nix
+++ b/server/thermoprint-server.nix
@@ -1,30 +1,32 @@
1{ mkDerivation, base, binary, bytestring, conduit, containers 1{ mkDerivation, base, binary, bytestring, conduit, containers
2, data-default-class, deepseq, dyre, either, encoding, exceptions 2, data-default-class, deepseq, dyre, either, encoding, exceptions
3, extended-reals, filelock, hspec, mmorph, monad-control 3, extended-reals, filelock, hspec, mmorph, monad-control
4, monad-logger, mtl, persistent, persistent-sqlite 4, monad-logger, mtl, network-uri, persistent, persistent-sqlite
5, persistent-template, QuickCheck, quickcheck-instances, resourcet 5, persistent-template, QuickCheck, quickcheck-instances, resourcet
6, servant-server, stdenv, stm, temporary, text, thermoprint-client 6, servant, servant-server, stdenv, stm, temporary, text
7, thermoprint-spec, time, transformers, wai, warp 7, thermoprint-client, thermoprint-spec, time, transformers, wai
8, wai-websockets, warp, websockets
8}: 9}:
9mkDerivation { 10mkDerivation {
10 pname = "thermoprint-server"; 11 pname = "thermoprint-server";
11 version = "1.0.0"; 12 version = "1.1.0";
12 src = ./.; 13 src = ./.;
13 isLibrary = true; 14 isLibrary = true;
14 isExecutable = true; 15 isExecutable = true;
15 libraryHaskellDepends = [ 16 libraryHaskellDepends = [
16 base binary bytestring conduit containers data-default-class 17 base binary bytestring conduit containers data-default-class
17 deepseq dyre either encoding exceptions extended-reals filelock 18 deepseq dyre either encoding exceptions extended-reals filelock
18 mmorph monad-control monad-logger mtl persistent 19 mmorph monad-control monad-logger mtl network-uri persistent
19 persistent-template resourcet servant-server stm text 20 persistent-template QuickCheck quickcheck-instances resourcet
20 thermoprint-spec time transformers wai warp 21 servant servant-server stm text thermoprint-spec time transformers
22 wai wai-websockets warp websockets
21 ]; 23 ];
22 executableHaskellDepends = [ 24 executableHaskellDepends = [
23 base monad-logger mtl persistent-sqlite resourcet 25 base monad-logger mtl persistent-sqlite resourcet
24 ]; 26 ];
25 testHaskellDepends = [ 27 testHaskellDepends = [
26 base exceptions hspec monad-logger mtl persistent-sqlite QuickCheck 28 base containers exceptions hspec monad-logger mtl persistent-sqlite
27 quickcheck-instances resourcet stm temporary text 29 QuickCheck quickcheck-instances resourcet stm temporary text
28 thermoprint-client thermoprint-spec transformers warp 30 thermoprint-client thermoprint-spec transformers warp
29 ]; 31 ];
30 homepage = "http://dirty-haskell.org/tags/thermoprint.html"; 32 homepage = "http://dirty-haskell.org/tags/thermoprint.html";