aboutsummaryrefslogtreecommitdiff
path: root/bbcode/thermoprint-bbcode.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bbcode/thermoprint-bbcode.nix')
-rw-r--r--bbcode/thermoprint-bbcode.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/bbcode/thermoprint-bbcode.nix b/bbcode/thermoprint-bbcode.nix
new file mode 100644
index 0000000..5521b10
--- /dev/null
+++ b/bbcode/thermoprint-bbcode.nix
@@ -0,0 +1,15 @@
1{ mkDerivation, attoparsec, base, hspec, QuickCheck
2, quickcheck-instances, stdenv, text
3}:
4mkDerivation {
5 pname = "thermoprint-bbcode";
6 version = "0.0.0";
7 src = ./.;
8 libraryHaskellDepends = [
9 attoparsec base QuickCheck quickcheck-instances text
10 ];
11 testHaskellDepends = [ attoparsec base hspec QuickCheck text ];
12 homepage = "http://dirty-haskell.org/tags/thermoprint.html";
13 description = "A parser for a subset of bbcode compatible with thermoprint-spec";
14 license = stdenv.lib.licenses.publicDomain;
15}