diff options
Diffstat (limited to 'ymir.nix')
-rw-r--r-- | ymir.nix | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -3,6 +3,7 @@ | |||
3 | let | 3 | let |
4 | luaPam = pkgs.callPackage ./custom/luaPam.nix {}; | 4 | luaPam = pkgs.callPackage ./custom/luaPam.nix {}; |
5 | luaPosix = pkgs.callPackage ./custom/luaPosix.nix {}; | 5 | luaPosix = pkgs.callPackage ./custom/luaPosix.nix {}; |
6 | luaSha2 = pkgs.callPackage ./custom/luaSha2.nix {}; | ||
6 | prosodyAuth = pkgs.callPackage ./custom/prosody-auth.nix {}; | 7 | prosodyAuth = pkgs.callPackage ./custom/prosody-auth.nix {}; |
7 | in { | 8 | in { |
8 | imports = | 9 | imports = |
@@ -30,7 +31,7 @@ in { | |||
30 | inherit (pkgs.lua51Packages) luasocket luasec luaexpat luafilesystem luabitop luaevent luazlib; | 31 | inherit (pkgs.lua51Packages) luasocket luasec luaexpat luafilesystem luabitop luaevent luazlib; |
31 | lua5 = pkgs.lua5_1; | 32 | lua5 = pkgs.lua5_1; |
32 | extraModules = [prosodyAuth]; | 33 | extraModules = [prosodyAuth]; |
33 | extraLibs = [luaPam luaPosix]; | 34 | extraLibs = [luaPam luaPosix luaSha2]; |
34 | }); | 35 | }); |
35 | }; | 36 | }; |
36 | 37 | ||
@@ -103,6 +104,8 @@ in { | |||
103 | ]; | 104 | ]; |
104 | extraConfig = '' | 105 | extraConfig = '' |
105 | authentication="custom" | 106 | authentication="custom" |
107 | custom_alias_file="/etc/prosody/aliases" | ||
108 | custom_alias_secret_file="/etc/prosody/alias_secret" | ||
106 | ''; | 109 | ''; |
107 | 110 | ||
108 | virtualHosts."xmpp.li" = { | 111 | virtualHosts."xmpp.li" = { |