diff options
Diffstat (limited to 'ymir.nix')
-rw-r--r-- | ymir.nix | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/ymir.nix b/ymir.nix new file mode 100644 index 00000000..e7b9b88c --- /dev/null +++ b/ymir.nix | |||
@@ -0,0 +1,61 @@ | |||
1 | { config, pkgs, ... }: | ||
2 | |||
3 | { | ||
4 | imports = | ||
5 | [ | ||
6 | ./ymir-hw.nix | ||
7 | ./custom/zsh.nix | ||
8 | ./users.nix | ||
9 | ]; | ||
10 | |||
11 | boot.loader.grub.enable = true; | ||
12 | boot.loader.grub.version = 2; | ||
13 | |||
14 | networking.hostName = "ymir"; | ||
15 | networking.hostId = "1c5c994e"; | ||
16 | |||
17 | environment.systemPackages = with pkgs; [ | ||
18 | git | ||
19 | mosh | ||
20 | rsync | ||
21 | tmux | ||
22 | zsh | ||
23 | ]; | ||
24 | |||
25 | # List services that you want to enable: | ||
26 | |||
27 | services.openssh = { | ||
28 | enable = true; | ||
29 | }; | ||
30 | |||
31 | services.fcron = { | ||
32 | enable = true; | ||
33 | systab = '' | ||
34 | %weekly * * nix-collect-garbage --delete-older-than '7d' | ||
35 | ''; | ||
36 | }; | ||
37 | |||
38 | networking.firewall = { | ||
39 | enable = true; | ||
40 | allowPing = true; | ||
41 | allowedTCPPorts = [ 22 | ||
42 | ]; | ||
43 | allowedUDPPortRanges = [ { from = 60000; to = 61000; } # mosh | ||
44 | ]; | ||
45 | }; | ||
46 | |||
47 | services.ntp = { | ||
48 | enable = false; | ||
49 | }; | ||
50 | |||
51 | services.chrony = { | ||
52 | enable = true; | ||
53 | }; | ||
54 | |||
55 | users.extraUsers.root = let | ||
56 | template = (import users/gkleen.nix); | ||
57 | in { | ||
58 | inherit (template) shell; | ||
59 | openssh.authorizedKeys.keyFiles = template.openssh.authorizedKeys.keyFiles; | ||
60 | }; | ||
61 | } | ||