summaryrefslogtreecommitdiff
path: root/ymir-hw.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ymir-hw.nix')
-rw-r--r--ymir-hw.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/ymir-hw.nix b/ymir-hw.nix
deleted file mode 100644
index 3ddf1035..00000000
--- a/ymir-hw.nix
+++ /dev/null
@@ -1,39 +0,0 @@
1# Do not modify this file! It was generated by ‘nixos-generate-config’
2# and may be overwritten by future invocations. Please make changes
3# to /etc/nixos/configuration.nix instead.
4{ config, lib, pkgs, ... }:
5
6{
7 imports =
8 [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
9 <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
10 ];
11
12 boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "virtio_blk" ];
13 boot.kernelModules = [ ];
14 boot.extraModulePackages = [ ];
15
16 fileSystems."/" =
17 {
18 device = "/dev/disk/by-label/ymir-root";
19 fsType = "ext4";
20 };
21
22 fileSystems."/boot" =
23 {
24 device = "/dev/disk/by-label/ymir-boot";
25 fsType = "ext2";
26 };
27
28 fileSystems."/home" =
29 {
30 device = "/dev/disk/by-label/ymir-home";
31 fsType = "ext4";
32 };
33
34 swapDevices =
35 [ { device = "/dev/disk/by-label/ymir-swap"; }
36 ];
37
38 nix.maxJobs = 2;
39}