summaryrefslogtreecommitdiff
path: root/ymir-hw.nix
diff options
context:
space:
mode:
Diffstat (limited to 'ymir-hw.nix')
-rw-r--r--ymir-hw.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/ymir-hw.nix b/ymir-hw.nix
new file mode 100644
index 00000000..cbb0d307
--- /dev/null
+++ b/ymir-hw.nix
@@ -0,0 +1,36 @@
1# Do not modify this file! It was generated by ‘nixos-generate-config’
2# and may be overwritten by future invocations. Please make changes
3# to /etc/nixos/configuration.nix instead.
4{ config, lib, pkgs, ... }:
5
6{
7 imports =
8 [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
9 <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
10 ];
11
12 boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "virtio_blk" ];
13 boot.kernelModules = [ ];
14 boot.extraModulePackages = [ ];
15
16 fileSystems."/" =
17 { device = "/dev/disk/by-uuid/e2d0b455-76a2-4e57-aff0-98d1fc2f7806";
18 fsType = "ext4";
19 };
20
21 fileSystems."/boot" =
22 { device = "/dev/disk/by-uuid/6e0ba525-114b-4998-952f-c859cf1471d6";
23 fsType = "ext2";
24 };
25
26 fileSystems."/home" =
27 { device = "/dev/disk/by-uuid/4284cea9-9a3f-4ee3-8295-ebffa8f6622c";
28 fsType = "ext4";
29 };
30
31 swapDevices =
32 [ { device = "/dev/disk/by-uuid/7957964d-aa60-44c4-9c59-9ae21fbca985"; }
33 ];
34
35 nix.maxJobs = 2;
36}