diff options
Diffstat (limited to 'vali.nix')
-rw-r--r-- | vali.nix | 11 |
1 files changed, 5 insertions, 6 deletions
@@ -4,11 +4,11 @@ | |||
4 | 4 | ||
5 | { config, pkgs, ... }: | 5 | { config, pkgs, ... }: |
6 | 6 | ||
7 | { | 7 | (import ./users.nix) { |
8 | imports = | 8 | imports = |
9 | [ # Include the results of the hardware scan. | 9 | [ # Include the results of the hardware scan. |
10 | ./vali-hw.nix | 10 | ./vali-hw.nix |
11 | ./users.nix | 11 | ./custom/zsh.nix |
12 | ]; | 12 | ]; |
13 | 13 | ||
14 | # Use the GRUB 2 boot loader. | 14 | # Use the GRUB 2 boot loader. |
@@ -66,10 +66,9 @@ | |||
66 | # services.xserver.desktopManager.kde4.enable = true; | 66 | # services.xserver.desktopManager.kde4.enable = true; |
67 | 67 | ||
68 | users.extraUsers.root = let | 68 | users.extraUsers.root = let |
69 | template = (import users/gkleen.nix).users.extraUsers.gkleen; | 69 | template = (import users/gkleen.nix) |
70 | in | 70 | in |
71 | { | 71 | with template; { |
72 | shell = template.shell; | 72 | inherit shell openssh.authorizedKeys.keyFiles; |
73 | openssh.authorizedKeys.keyFiles = template.openssh.authorizedKeys.keyFiles; | ||
74 | }; | 73 | }; |
75 | } | 74 | } |