summaryrefslogtreecommitdiff
path: root/users/root.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/root.nix')
-rw-r--r--users/root.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/users/root.nix b/users/root.nix
index 88cc6b26..95fe37c4 100644
--- a/users/root.nix
+++ b/users/root.nix
@@ -1 +1,7 @@
1import ./gkleen 1{ flake, lib, config, hostName, ... }:
2{
3 users.users.root = lib.mkIf (flake.nixosModules.accounts ? "gkleen@${hostName}") {
4 inherit (config.users.users."gkleen") hashedPassword shell;
5 openssh.authorizedKeys.keyFiles = config.users.users."gkleen".openssh.authorizedKeys.keyFiles;
6 };
7}