summaryrefslogtreecommitdiff
path: root/users/gkleen@odin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/gkleen@odin.nix')
-rw-r--r--users/gkleen@odin.nix19
1 files changed, 0 insertions, 19 deletions
diff --git a/users/gkleen@odin.nix b/users/gkleen@odin.nix
index a52713cd..9fb2d5b4 100644
--- a/users/gkleen@odin.nix
+++ b/users/gkleen@odin.nix
@@ -9,24 +9,5 @@
9 sha256 = "02a4py7zx9ib49kijpjckya1pb8xlb3gmp7s1dybsdjmwqbdyzx7"; 9 sha256 = "02a4py7zx9ib49kijpjckya1pb8xlb3gmp7s1dybsdjmwqbdyzx7";
10 }; 10 };
11 }); 11 });
12
13 haskell = pkgs.haskell // {
14 packages = pkgs.haskell.packages // {
15 ghc822 = pkgs.haskell.packages.ghc822.extend (selfH: superH: {
16 ListLike = pkgs.haskell.lib.overrideCabal superH.ListLike (oldAttrs: {
17 libraryHaskellDepends = (oldAttrs.libraryHaskellDepends or []) ++ (with selfH; [semigroups]);
18 });
19 });
20 };
21 };
22
23 buchhaltung = pkgs.haskell.lib.overrideCabal pkgs.haskell.packages.ghc822.buchhaltung (oldAttrs: {
24 buildDepends = (oldAttrs.buildDepends or []) ++ [ pkgs.makeWrapper ];
25 postBuild = ''
26 ${oldAttrs.postBuild or ""}
27 wrapProgram $out/bin/buchhaltung \
28 --prefix PATH : ${pkgs.lib.makeBinPath (with pkgs; [ aqbanking dbacl ])}
29 '';
30 });
31 } // (import ../utils/nix/default.nix) pkgs (import <nixpkgs> {}); 12 } // (import ../utils/nix/default.nix) pkgs (import <nixpkgs> {});
32} 13}