diff options
Diffstat (limited to 'users/gkleen@bragi.nix')
-rw-r--r-- | users/gkleen@bragi.nix | 30 |
1 files changed, 15 insertions, 15 deletions
diff --git a/users/gkleen@bragi.nix b/users/gkleen@bragi.nix index 47836f7f..e0b50300 100644 --- a/users/gkleen@bragi.nix +++ b/users/gkleen@bragi.nix | |||
@@ -36,28 +36,28 @@ | |||
36 | attoparsecExpr = callPackage ../custom/attoparsec-expr.nix {}; | 36 | attoparsecExpr = callPackage ../custom/attoparsec-expr.nix {}; |
37 | shellMonad = callPackage ../custom/shell-monad.nix {}; | 37 | shellMonad = callPackage ../custom/shell-monad.nix {}; |
38 | beuteltier = callPackage ../custom/beuteltier.nix { fetchgit = pkgs.fetchgit; }; | 38 | beuteltier = callPackage ../custom/beuteltier.nix { fetchgit = pkgs.fetchgit; }; |
39 | wombat = callPackage ../custom/wombat.nix { fetchgit = pkgs.fetchgit; }; | ||
40 | opossum = callPackage ../custom/opossum.nix { fetchgit = pkgs.fetchgit; }; | 39 | opossum = callPackage ../custom/opossum.nix { fetchgit = pkgs.fetchgit; }; |
41 | opossumWrapper = callPackage ../custom/opossum-wrapper.nix { | 40 | opossumWrapper = callPackage ../custom/opossum-wrapper.nix { |
42 | stdenv = pkgs.stdenv; | 41 | stdenv = pkgs.stdenv; |
43 | makeWrapper = pkgs.makeWrapper; | 42 | makeWrapper = pkgs.makeWrapper; |
44 | }; | 43 | }; |
44 | wombat = callPackage ../custom/wombat.nix { fetchgit = pkgs.fetchgit; }; | ||
45 | wombatWrapper = pkgs.stdenv.mkDerivation { | ||
46 | name = "wombat-wrapper"; | ||
47 | src = self.wombat; | ||
48 | unpackPhase = "true"; | ||
49 | buildInputs = [ pkgs.makeWrapper pkgs.rsync ]; | ||
50 | installPhase = '' | ||
51 | mkdir -p $out | ||
52 | rsync -a $src/ $out/ | ||
53 | chmod u+w $out/bin | ||
54 | wrapProgram $out/bin/wombat \ | ||
55 | --prefix PATH : ${pkgs.ffmpeg}/bin \ | ||
56 | --prefix PATH : ${pkgs.youtube-dl}/bin | ||
57 | ''; | ||
58 | }; | ||
45 | }; | 59 | }; |
46 | } | 60 | } |
47 | ); | 61 | ); |
48 | wombatWrapper = pkgs.stdenv.mkDerivation { | ||
49 | name = "wombat-wrapper"; | ||
50 | src = myHaskellPackages.wombat; | ||
51 | unpackPhase = "true"; | ||
52 | buildInputs = [ pkgs.makeWrapper pkgs.rsync ]; | ||
53 | installPhase = '' | ||
54 | mkdir -p $out | ||
55 | rsync -a $src/ $out/ | ||
56 | chmod u+w $out/bin | ||
57 | wrapProgram $out/bin/wombat \ | ||
58 | --prefix PATH : ${pkgs.ffmpeg}/bin \ | ||
59 | --prefix PATH : ${pkgs.youtube-dl}/bin | ||
60 | ''; | ||
61 | }; | ||
62 | }; | 62 | }; |
63 | } | 63 | } |