diff options
Diffstat (limited to 'users/gkleen@bragi.nix')
-rw-r--r-- | users/gkleen@bragi.nix | 23 |
1 files changed, 0 insertions, 23 deletions
diff --git a/users/gkleen@bragi.nix b/users/gkleen@bragi.nix index e3c099f2..b67696a5 100644 --- a/users/gkleen@bragi.nix +++ b/users/gkleen@bragi.nix | |||
@@ -35,34 +35,11 @@ | |||
35 | in { | 35 | in { |
36 | attoparsecExpr = callPackage ../custom/attoparsec-expr.nix {}; | 36 | attoparsecExpr = callPackage ../custom/attoparsec-expr.nix {}; |
37 | shellMonad = callPackage ../custom/shell-monad.nix {}; | 37 | shellMonad = callPackage ../custom/shell-monad.nix {}; |
38 | beuteltier = callPackage ../custom/beuteltier.nix {}; | ||
39 | opossum = callPackage ../custom/opossum.nix {}; | ||
40 | opossumWrapper = callPackage ../custom/opossum-wrapper.nix {}; | ||
41 | wombat = callPackage ../custom/wombat.nix {}; | ||
42 | wombatWrapper = pkgs.stdenv.mkDerivation { | ||
43 | name = "wombat-wrapper"; | ||
44 | src = self.wombat; | ||
45 | unpackPhase = "true"; | ||
46 | buildInputs = [ pkgs.makeWrapper pkgs.rsync ]; | ||
47 | installPhase = '' | ||
48 | mkdir -p $out | ||
49 | rsync -a $src/ $out/ | ||
50 | chmod u+w $out/bin | ||
51 | wrapProgram $out/bin/wombat \ | ||
52 | --prefix PATH : ${pkgs.ffmpeg}/bin \ | ||
53 | --prefix PATH : ${pkgs.wget}/bin \ | ||
54 | --prefix PATH : ${pkgs.youtube-dl}/bin | ||
55 | ''; | ||
56 | }; | ||
57 | filelock = callPackage ../custom/filelock.nix {}; | 38 | filelock = callPackage ../custom/filelock.nix {}; |
58 | trivmix = callPackage ../custom/trivmix.nix {}; | 39 | trivmix = callPackage ../custom/trivmix.nix {}; |
59 | }; | 40 | }; |
60 | } | 41 | } |
61 | ); | 42 | ); |
62 | runOpossum = pkgs.callPackage ../custom/run-opossum_bragi.nix { | ||
63 | wombat = myHaskellPackages.wombatWrapper; | ||
64 | opossum = myHaskellPackages.opossumWrapper; | ||
65 | }; | ||
66 | adjmix = let trivmix = myHaskellPackages.trivmix; in | 43 | adjmix = let trivmix = myHaskellPackages.trivmix; in |
67 | pkgs.stdenv.mkDerivation { | 44 | pkgs.stdenv.mkDerivation { |
68 | name = "adjmix"; | 45 | name = "adjmix"; |