summaryrefslogtreecommitdiff
path: root/user-profiles/yt-dlp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user-profiles/yt-dlp.nix')
-rw-r--r--user-profiles/yt-dlp.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/user-profiles/yt-dlp.nix b/user-profiles/yt-dlp.nix
new file mode 100644
index 00000000..946fd8d0
--- /dev/null
+++ b/user-profiles/yt-dlp.nix
@@ -0,0 +1,17 @@
1{ config, lib, userName, pkgs, ... }:
2{
3 home-manager.users.${userName} = {
4 home.packages = with pkgs; [ yt-dlp ];
5 xdg.configFile."yt-dlp/config".text = ''
6 --netrc
7 --mark-watched
8 --format ${lib.concatStringsSep "/" [
9 "bestvideo[width<=1920][height<=1080][fps<=60][protocol!=http_dash_segments]+bestaudio[protocol!=http_dash_segments]"
10 "best[width<=1920][height<=1080][fps<=60][protocol!=http_dash_segments]"
11 # "bestvideo[width<=2560][height<=1440][fps<=60][protocol!=http_dash_segments]+bestaudio[protocol!=http_dash_segments]"
12 # "best[width<=2560][height<=1440][fps<=60][protocol!=http_dash_segments]"
13 "best[protocol!=http_dash_segments]"
14 ]}
15 '';
16 };
17}