summaryrefslogtreecommitdiff
path: root/user-profiles/utils.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user-profiles/utils.nix')
-rw-r--r--user-profiles/utils.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/user-profiles/utils.nix b/user-profiles/utils.nix
new file mode 100644
index 00000000..5407276a
--- /dev/null
+++ b/user-profiles/utils.nix
@@ -0,0 +1,25 @@
1{ userName, pkgs, ... }:
2{
3 home-manager.users.${userName} = {
4 programs = {
5 htop = {
6 enable = true;
7 settings = {
8 delay = 5;
9 highlightBaseName = true;
10 treeView = true;
11 };
12 };
13
14 jq.enable = true;
15 };
16
17 home.packages = with pkgs; [
18 autossh usbutils pciutils exa ag pwgen unzip magic-wormhole
19 qrencode tty-clock dnsutils openssl sshfs psmisc mosh tree
20 vnstat file pv bc fast-cli zip nmap aspell aspellDicts.de
21 aspellDicts.en borgbackup man-pages rsync socat telnet yq
22 cached-nix-shell persistent-nix-shell rage
23 ];
24 };
25}