summaryrefslogtreecommitdiff
path: root/user-profiles/utils.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user-profiles/utils.nix')
-rw-r--r--user-profiles/utils.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/user-profiles/utils.nix b/user-profiles/utils.nix
new file mode 100644
index 00000000..1de9e4eb
--- /dev/null
+++ b/user-profiles/utils.nix
@@ -0,0 +1,22 @@
1{ userName, pkgs, ... }:
2{
3 home-manager.users.${userName} = {
4 programs = {
5 htop = {
6 enable = true;
7 delay = 5;
8 highlightBaseName = true;
9 treeView = true;
10 };
11
12 jq.enable = true;
13 };
14
15 home.packages = with pkgs; [
16 autossh usbutils pciutils exa ag pwgen unzip magic-wormhole
17 qrencode tty-clock dnsutils openssl sshfs psmisc mosh tree
18 vnstat file pv bc fast-cli zip nmap aspell aspellDicts.de
19 aspellDicts.en borgbackup man-pages rsync socat telnet yq
20 ];
21 };
22}