summaryrefslogtreecommitdiff
path: root/user-profiles/feeds/module.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user-profiles/feeds/module.nix')
-rw-r--r--user-profiles/feeds/module.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/user-profiles/feeds/module.nix b/user-profiles/feeds/module.nix
index 9f7bcf9e..8008a4b8 100644
--- a/user-profiles/feeds/module.nix
+++ b/user-profiles/feeds/module.nix
@@ -11,7 +11,7 @@ let
11 imm = flakeInputs.imm.defaultPackage.${system}.overrideAttrs (oldAttrs: { 11 imm = flakeInputs.imm.defaultPackage.${system}.overrideAttrs (oldAttrs: {
12 buildInputs = 12 buildInputs =
13 let 13 let
14 oldDepends = filter (attr: if attr ? name then builtins.match "uri-bytestring(-.*)?" attr.name == null else true) (oldAttrs.buildInputs or []); 14 oldDepends = filter (attr: if attr ? name then builtins.match "(uri-bytestring|atom-conduit)(-.*)?" attr.name == null else true) (oldAttrs.buildInputs or []);
15 newDepends = [ 15 newDepends = [
16 (pkgs.haskellPackages.uri-bytestring.overrideAttrs (_: { 16 (pkgs.haskellPackages.uri-bytestring.overrideAttrs (_: {
17 src = pkgs.fetchFromGitHub { 17 src = pkgs.fetchFromGitHub {
@@ -22,6 +22,15 @@ let
22 fetchSubmodules = true; 22 fetchSubmodules = true;
23 }; 23 };
24 })) 24 }))
25 (pkgs.haskellPackages.atom-conduit.overrideAttrs (_: {
26 src = pkgs.fetchFromGitHub {
27 owner = "gkleen";
28 repo = "atom-conduit";
29 rev = "af33d1162d84f1fca00fe92a2e47f0a1a5275b4b";
30 sha256 = "FbfA4cvF0Z9Q4ethJmXWAQmWdFZNds7XRIMWFXc+ByA=";
31 fetchSubmodules = true;
32 };
33 }))
25 ]; 34 ];
26 in oldDepends ++ newDepends; 35 in oldDepends ++ newDepends;
27 }); 36 });