summaryrefslogtreecommitdiff
path: root/user-profiles/core.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user-profiles/core.nix')
-rw-r--r--user-profiles/core.nix28
1 files changed, 5 insertions, 23 deletions
diff --git a/user-profiles/core.nix b/user-profiles/core.nix
index 6f473b1a..91685611 100644
--- a/user-profiles/core.nix
+++ b/user-profiles/core.nix
@@ -1,26 +1,8 @@
1{ flake, userName, lib, customUtils, ... }: 1{ userName, ... }:
2let 2{
3 userProfileSet = customUtils.types.attrNameSet (lib.zipAttrs (lib.attrValues flake.nixosModules.userProfiles)); 3 users.users.${userName} = {}; # Just make sure the user is created
4in {
5 options = {
6 users.users = lib.mkOption {
7 type = lib.types.attrsOf (lib.types.submodule {
8 options.profiles = lib.mkOption {
9 type = userProfileSet;
10 default = [];
11 description = ''
12 Set (list without duplicates) of ‘userProfiles’ enabled for this user
13 '';
14 };
15 });
16 };
17 };
18
19 config = {
20 users.users.${userName} = {}; # Just make sure the user is created
21 4
22 home-manager.users.${userName} = { 5 home-manager.users.${userName} = {
23 manual.manpages.enable = true; 6 manual.manpages.enable = true;
24 };
25 }; 7 };
26} 8}