diff options
Diffstat (limited to 'system-profiles/rebuild-machines/default.nix')
-rw-r--r-- | system-profiles/rebuild-machines/default.nix | 12 |
1 files changed, 6 insertions, 6 deletions
diff --git a/system-profiles/rebuild-machines/default.nix b/system-profiles/rebuild-machines/default.nix index fe9a5f14..e434d2e4 100644 --- a/system-profiles/rebuild-machines/default.nix +++ b/system-profiles/rebuild-machines/default.nix | |||
@@ -68,7 +68,7 @@ in { | |||
68 | }; | 68 | }; |
69 | }; | 69 | }; |
70 | }; | 70 | }; |
71 | default = { flake.url = "git+ssh://${cfg.repoHost}/nixos?ref=flakes"; flakeOutput = hostName; }; | 71 | default = { flake = { type = "git"; url = "ssh://${cfg.repoHost}/nixos"; ref = "flakes"; } flakeOutput = hostName; }; |
72 | description = '' | 72 | description = '' |
73 | The Flake URI of the NixOS configuration to build. | 73 | The Flake URI of the NixOS configuration to build. |
74 | ''; | 74 | ''; |
@@ -122,15 +122,15 @@ in { | |||
122 | } | 122 | } |
123 | ]; | 123 | ]; |
124 | 124 | ||
125 | sops.secrets = lib.mkIf (!(isNull cfg.sopsConfig)) { | 125 | sops.secrets = mkIf (!(isNull cfg.sopsConfig)) { |
126 | "${cfg.sopsName}" = { | 126 | "${cfg.sopsName}" = { |
127 | sopsFile = cfg.repoPrivkey; | 127 | sopsFile = cfg.repoPrivkey; |
128 | } // cfg.sopsConfig; | 128 | } // cfg.sopsConfig; |
129 | }; | 129 | }; |
130 | 130 | ||
131 | environment.systemPackages = [ rebuildScript ]; | 131 | environment.systemPackages = [rebuildScript]; |
132 | 132 | ||
133 | systemd.services."rebuild-${hostName}" = lib.mkIf (cfg.period != null) { | 133 | systemd.services."rebuild-${hostName}" = mkIf (cfg.period != null) { |
134 | description = "Upgrade System on Next Boot"; | 134 | description = "Upgrade System on Next Boot"; |
135 | requisite = [ "network.target" ]; | 135 | requisite = [ "network.target" ]; |
136 | after = [ "network.target" ]; | 136 | after = [ "network.target" ]; |
@@ -144,7 +144,7 @@ in { | |||
144 | }; | 144 | }; |
145 | }; | 145 | }; |
146 | 146 | ||
147 | systemd.timers."rebuild-${hostName}" = lib.mkIf (cfg.period != null) { | 147 | systemd.timers."rebuild-${hostName}" = mkIf (cfg.period != null) { |
148 | wantedBy = [ "timers.target" ]; | 148 | wantedBy = [ "timers.target" ]; |
149 | timerConfig = { | 149 | timerConfig = { |
150 | OnCalendar = cfg.period; | 150 | OnCalendar = cfg.period; |
@@ -152,7 +152,7 @@ in { | |||
152 | }; | 152 | }; |
153 | }; | 153 | }; |
154 | 154 | ||
155 | nix.registry = lib.mkIf (cfg.flake != null) { | 155 | nix.registry = mkIf (cfg.flake != null) { |
156 | ${cfg.flake.name} = { | 156 | ${cfg.flake.name} = { |
157 | exact = false; | 157 | exact = false; |
158 | to = cfg.flake.flake; | 158 | to = cfg.flake.flake; |