summaryrefslogtreecommitdiff
path: root/system-profiles/core.nix
diff options
context:
space:
mode:
Diffstat (limited to 'system-profiles/core.nix')
-rw-r--r--system-profiles/core.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/system-profiles/core.nix b/system-profiles/core.nix
index 158757d1..5b78c0fd 100644
--- a/system-profiles/core.nix
+++ b/system-profiles/core.nix
@@ -53,12 +53,11 @@ in {
53 "nixpkgs=${flakeInputs.nixpkgs.legacyPackages.${config.nixpkgs.system}.path}" 53 "nixpkgs=${flakeInputs.nixpkgs.legacyPackages.${config.nixpkgs.system}.path}"
54 "nixpkgs-overlays=${flake.overlays-path.${config.nixpkgs.system}}" 54 "nixpkgs-overlays=${flake.overlays-path.${config.nixpkgs.system}}"
55 ]; 55 ];
56 registry = { 56 registry =
57 nixpkgs.flake = flakeInputs.nixpkgs; 57 let override = { self = "nixos"; };
58 home-manager.flake = flakeInputs.home-manager; 58 in lib.mapAttrs' (inpName: inpFlake: lib.nameValuePair
59 sops-nix.flake = flakeInputs.sops-nix; 59 (override.${inpName} or inpName)
60 nixos.flake = flake; 60 { flake = inpFlake; } ) flakeInputs;
61 };
62 }; 61 };
63 62
64 users.mutableUsers = false; 63 users.mutableUsers = false;