summaryrefslogtreecommitdiff
path: root/sif/boot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sif/boot.nix')
-rw-r--r--sif/boot.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/sif/boot.nix b/sif/boot.nix
new file mode 100644
index 00000000..00d42b99
--- /dev/null
+++ b/sif/boot.nix
@@ -0,0 +1,26 @@
1{ config, lib, pkgs, ... }:
2
3{
4 boot = {
5 initrd = {
6 luks.devices = [
7 { name = "nvm0"; device = "/dev/disk/by-uuid/fe641e81-0812-4181-a5f6-382ebba509bb"; }
8 { name = "nvm1"; device = "/dev/disk/by-uuid/43df1ba8-1728-4193-8855-920a82d4494a"; }
9 ];
10 kernelModules = [ "dm-snapshot" ];
11 availableKernelModules = [ "fbcon" "xhci_pci" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
12 };
13 };
14
15
16 # Use the systemd-boot EFI boot loader.
17 loader = {
18 systemd-boot.enable = true;
19 efi.canTouchEfiVariables = true;
20 timeout = null;
21 };
22
23 plymouth.enable = true;
24
25 kernelParams = [ "intel_pstate=no_hwp" "quiet" ];
26}