summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 5f883cd1..c50c1991 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,10 +1,9 @@
1inputs@{ system, self, deploy-rs, nvfetcher, nixpkgs, ... }: 1inputs@{ system, self, deploy-rs, nvfetcher, nixpkgs, ca-util, ... }:
2let 2let
3 pkgs = self.legacyPackages.${system}; 3 pkgs = self.legacyPackages.${system};
4 utils = import ./utils { inherit (nixpkgs) lib; }; 4 utils = import ./utils { inherit (nixpkgs) lib; };
5 inherit (utils) nixImport; 5 inherit (utils) nixImport;
6in pkgs.mkShell { 6in pkgs.mkShell {
7 name = "nixos";
8 nativeBuildInputs = builtins.attrValues self.packages.${system} ++ (with pkgs; [ 7 nativeBuildInputs = builtins.attrValues self.packages.${system} ++ (with pkgs; [
9 sops 8 sops
10 wireguard-tools 9 wireguard-tools
@@ -14,5 +13,7 @@ in pkgs.mkShell {
14 knot-dns 13 knot-dns
15 yq 14 yq
16 nvfetcher.packages.${system}.default 15 nvfetcher.packages.${system}.default
16 ca-util.packages.${system}.ca
17 ]); 17 ]);
18
18} 19}