summaryrefslogtreecommitdiff
path: root/overlays/worktime/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/worktime/pyproject.toml')
-rw-r--r--overlays/worktime/pyproject.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/overlays/worktime/pyproject.toml b/overlays/worktime/pyproject.toml
new file mode 100644
index 00000000..f3fd3dfa
--- /dev/null
+++ b/overlays/worktime/pyproject.toml
@@ -0,0 +1,22 @@
1[tool.poetry]
2name = "worktime"
3version = "0.1.0"
4description = ""
5authors = ["Gregor Kleen <gkleen@yggdrasil.li>"]
6
7[tool.poetry.dependencies]
8python = "^3.10"
9pyxdg = "^0.28"
10python-dateutil = "^2.8.2"
11uritools = "^4.0.1"
12requests = "^2.28.2"
13configparser = "^5.3.0"
14tabulate = "^0.9.0"
15backoff = "^2.2.1"
16
17[tool.poetry.scripts]
18worktime = "worktime.__main__:main"
19
20[build-system]
21requires = ["poetry-core"]
22build-backend = "poetry.core.masonry.api" \ No newline at end of file