summaryrefslogtreecommitdiff
path: root/overlays/waybar-systemd-inhibit/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/waybar-systemd-inhibit/default.nix')
-rw-r--r--overlays/waybar-systemd-inhibit/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/overlays/waybar-systemd-inhibit/default.nix b/overlays/waybar-systemd-inhibit/default.nix
new file mode 100644
index 00000000..88322ef5
--- /dev/null
+++ b/overlays/waybar-systemd-inhibit/default.nix
@@ -0,0 +1,35 @@
1{ prev, final, flakeInputs, ... }:
2
3with flakeInputs;
4
5let
6 workspace = uv2nix.lib.workspace.loadWorkspace { workspaceRoot = ./.; };
7 overlay = workspace.mkPyprojectOverlay {
8 sourcePreference = "wheel";
9 };
10 python = final.python312;
11 # hacks = final.callPackage pyproject-nix.build.hacks { };
12 pythonSet =
13 (final.callPackage pyproject-nix.build.packages {
14 inherit python;
15 }).overrideScope
16 (
17 prev.lib.composeManyExtensions [
18 pyproject-build-systems.overlays.default
19 overlay
20 # (final: prev: {
21 # pygobject = hacks.nixpkgsPrebuilt {
22 # from = python.pkgs.pygobject3;
23 # };
24 # })
25 ]
26 );
27 virtualEnv = pythonSet.mkVirtualEnv "waybar-systemd-inhibit-env" workspace.deps.default;
28in {
29 waybar-systemd-inhibit = virtualEnv.overrideAttrs (oldAttrs: {
30 meta = (oldAttrs.meta or {}) // {
31 mainProgram = "waybar-systemd-inhibit";
32 };
33 nativeBuildInputs = (oldAttrs.nativeBuildInputs or []) ++ [ final.gobject-introspection final.wrapGAppsHook ];
34 });
35}