summaryrefslogtreecommitdiff
path: root/overlays/urxvt/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/urxvt/default.nix')
-rw-r--r--overlays/urxvt/default.nix21
1 files changed, 0 insertions, 21 deletions
diff --git a/overlays/urxvt/default.nix b/overlays/urxvt/default.nix
deleted file mode 100644
index 77a2c51f..00000000
--- a/overlays/urxvt/default.nix
+++ /dev/null
@@ -1,21 +0,0 @@
1{ final, prev, ... }: {
2 rxvt_unicode-with-plugins = prev.rxvt-unicode.override {
3 configure = { availablePlugins, ... }: {
4 plugins = [ final.urxvt_osc_52 ] ++ builtins.attrValues availablePlugins;
5 };
6 };
7 urxvt_osc_52 = prev.stdenv.mkDerivation {
8 name = "rxvt_unicode-osc_52-0";
9 src = ./52-osc.pl;
10 unpackPhase = ''
11 cp $src 52-osc
12 '';
13 buildPhase = ''
14 sed -i 's|#! perl|#! ${final.perl}/bin/perl|g' 52-osc
15 '';
16 installPhase = ''
17 mkdir -p $out/lib/urxvt/perl
18 cp 52-osc $out/lib/urxvt/perl
19 '';
20 };
21}