summaryrefslogtreecommitdiff
path: root/overlays/spm/spm.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/spm/spm.nix')
-rw-r--r--overlays/spm/spm.nix20
1 files changed, 11 insertions, 9 deletions
diff --git a/overlays/spm/spm.nix b/overlays/spm/spm.nix
index 533f190a..2abebe64 100644
--- a/overlays/spm/spm.nix
+++ b/overlays/spm/spm.nix
@@ -1,11 +1,12 @@
1{ mkDerivation, aeson, attoparsec, base, bytestring 1{ mkDerivation, aeson, aeson-casing, attoparsec, base, bytestring
2, case-insensitive, cryptonite, exceptions, file-embed, filepath 2, case-insensitive, containers, cryptonite, exceptions, file-embed
3, hpack, http-api-data, http-types, jose, lens, lens-aeson, lib 3, filepath, hpack, http-api-data, http-types, jose, lens
4, mmorph, monad-logger, MonadRandom, mtl, optparse-applicative 4, lens-aeson, lib, mmorph, monad-logger, MonadRandom, mtl
5, path-pieces, persistent, persistent-postgresql, random 5, optparse-applicative, path-pieces, persistent
6, resource-pool, servant, servant-server, template-haskell, text 6, persistent-postgresql, random, resource-pool, servant
7, th-lift-instances, time, transformers, unliftio-core, uuid 7, servant-server, template-haskell, text, th-lift-instances, time
8, vector, wai, wai-app-static, wai-extra, warp, warp-systemd 8, transformers, unliftio-core, uuid, vector, wai, wai-app-static
9, wai-extra, warp, warp-systemd
9}: 10}:
10mkDerivation { 11mkDerivation {
11 pname = "spm"; 12 pname = "spm";
@@ -14,7 +15,8 @@ mkDerivation {
14 isLibrary = true; 15 isLibrary = true;
15 isExecutable = true; 16 isExecutable = true;
16 libraryHaskellDepends = [ 17 libraryHaskellDepends = [
17 aeson base case-insensitive jose lens servant text uuid 18 aeson aeson-casing base case-insensitive containers jose lens
19 servant text uuid
18 ]; 20 ];
19 libraryToolDepends = [ hpack ]; 21 libraryToolDepends = [ hpack ];
20 executableHaskellDepends = [ 22 executableHaskellDepends = [